FREAK is another serious flaw in the Web's encryption

US export restrictions on encryption technology from the 1990s have come back to haunt the modern Web

Experts are warning of a serious security flaw that has apparently gone undetected for years and can weaken encrypted connections between computers and websites, potentially undermining security across the Internet.

The flaw, which has been dubbed FREAK, affects the widely used Secure Sockets Layer protocol and its successor, Transport Layer Security, and can allow an attacker to intercept supposedly encrypted traffic as it moves between clients and servers.

The flaw affects many popular websites, as well as programs including Apple's Safari browser and Google's Android mobile OS, security experts say. Applications that use a version of OpenSSL prior to 1.0.1k are also vulnerable to the bug, detailed in this advisory.

The problem stems from export restrictions imposed by the U.S. government in the early 1990s, which prohibited software makers from shipping products with strong encryption overseas, wrote Ed Felten, professor of computer science and public affairs at Princeton University.

That meant some companies shipped a version of their products with weaker encryption keys for use overseas. When the law was changed and it became legal to export stronger encryption, "the export mode feature was not removed from the protocol because some software still depended on it," Felten wrote.

The vulnerability that has come to light now essentially allows attackers to downgrade the security of connections from strong encryption to that of the weaker, export-grade encryption.

Servers and devices that use OpenSSL, an open-source encryption program, are vulnerable, including many Google and Apple devices, embedded systems and other products, according to an advisory. Servers or clients that accept the RSA_EXPORT cipher suites are at risk. FREAK stands for Factoring attack on RSA-EXPORT Keys.

The keys can be downgraded by performing a man-in-the-middle attack that interferes with the set-up process of an encrypted connection. Although there are defenses in the SSL/TLS protocol to prevent such tampering, they can be worked around. The weaker, 512-bit key can be revealed using today's powerful computers, and the data traffic can then be decrypted.

Today's protocols use longer encryption keys, and the standard is 2,048-bit RSA. The 512-bit keys were considered secure two decades ago, but an attacker could recover the key they need quite easily today using a public cloud service.

"Back in the '90s, that would have required a heavy-duty computation, but today it takes about seven hours on Amazon EC2 and costs about $100," Felten wrote.

Companies are moving fast to fix the issue. Akamai, a content delivery network that supports a high number of websites, said it has distributed a fix for its network.

However, some clients may still be vulnerable, wrote Bill Brenner of Akamai.

"We can't fix those clients, but we can avoid the problem by disabling export ciphers," he wrote. "Because this is a client side issue, we've reached out to our customers and are working with them to make this change."

The vulnerability was discovered by Karthikeyan Bhargavan of INRIA, a French science and technology research institute, and by Microsoft Research. A technical paper describing FREAK is due to be presented at the IEEE's Security and Privacy conference in San Jose, California, in May.

Send news tips and comments to jeremy_kirk@idg.com. Follow me on Twitter: @jeremy_kirk

Join the Computerworld New Zealand newsletter!

Error: Please check your email address.

Tags AppleGooglesecurityencryptionExploits / vulnerabilities

More about AppleBillGoogleIEEEMicrosoftRSATransport

Show Comments
[]