Explorer hole can crash PCs and compromise systems

An unpatched flaw in Internet Explorer may allow attackers to execute code via a malicious website.

An unpatched flaw in Internet Explorer may allow attackers to execute code via a malicious website. The bug affects the latest versions of Explorer patched with Service Pack 2 (SP2) as well as older editions, according to SEC Consult.

Cisco has also reported a flaw in its IOS operating system, widely used in routers and other networking hardware, that could allow attackers to bypass authentication.

The Explorer problem involves the way the javaprxy.dll COM object works with object tags, according to SEC Consult, but is part of a wider problem. "We found that at least 20 of the objects available on an average XP system either lead to an instant crash or an exception after a few reloads," the firm said in an advisory.

Crashes are one thing, but the javaprxy.dll flaw may also allow an attacker to run malicious script code, although neither Microsoft nor SEC Consult could confirm that this was more than a potential outcome. "An attacker who successfully exploited this vulnerability could run malicious script code on the local system. This could allow an attacker to take complete control of the affected system," said Microsoft in an advisory.

A user could be affected by the bug by viewing a website containing the malicious code, Microsoft said. An attacker might lure a user to a malicious site or compromise another site and embed the malicious code there.

Microsoft chided SEC Consult for publicly discussing the vulnerability. "While this issue was first reported to Microsoft responsibly, details about the reported vulnerability have been made public. Microsoft continues to encourage responsible disclosure of vulnerabilities," the company said in its advisory. Microsoft didn't initially confirm the bug when SEC Consult reported it earlier this month, according to the security firm.

Microsoft said it may patch the bug after finishing its investigation. In the meantime, it recommended users to set Explorer's security settings to "high", via a process described in the advisory. Unfortunately, this setting means users will be prompted before the execution of every ActiveX control.

Independent security firm Secunia gave the flaw a "highly critical" rating.

Cisco said a vulnerability in Cisco IOS could be exploited to bypass the Remote Dial In User Service (RADIUS), which could allow an attacker to access a vulnerable network.

The bug affects particular versions of IOS, only affects those using RADIUS, and only affects those with a particular configuration setting - the fallback method must be set to "none". Cisco specifies which versions are vulnerable, and makes patches available, in an advisory on its website.

The company said workarounds are also possible to make the bug less dangerous.

More about Cisco Systems Australia Pty LtdMicrosoftSECVIA

Comments

Comments are now closed

Intel's MinnowBoard Max coming in late, commanding higher prices

READ THIS ARTICLE
DO NOT SHOW THIS BOX AGAIN [ x ]